mobilEcho compatibility with the new iPad (updated)

1 Star2 Stars3 Stars4 Stars5 Stars
Loading...
  • Product:
    mobilEcho
  • Revised:
    3/17/2012
  • Reviewed:
    3/16/2012

To use mobilEcho on the new iPad (third generation), please update to the latest version through the App Store. We added support for the new iPad in version 3.5.2 on March 17, 2012.

If you have any questions or find any issues, please open a support case at http://support.grouplogic.com/request.

Tags: , , ,