Posts Tagged ‘mac os x 10.4.8’

Repairing MassTransit 5.1 and 6.0 Enterprise, Standard and Premier Servers After Mac OS X 10.4.8 Server Update (PPC)

Thursday, November 16th, 2006

Symptom:

Upgrading Mac OS to 10.4.8 may disable the MassTransit Engine.

Steps to Reproduce:

This article assumes you have the following third-party component versions installed on your MassTransit server:

Mac OS X Server MassTransit MySQL Apache PHP 5
PPC Enterprise/Standard/Premier 5.0.x 1.3.xx 5.2.x
Intel Enterprise/Standard/Premier 5.0.x 1.3.x 5.2.x

To Reproduce:

Upgrade Mac OS X 10.4.x Server to 10.4.8. Launch MassTransit Engine.app and the icon bounces on the Dock and then stops. A MySQL connection dialog will pop-up explaining that the MassTransit Engine could not connect to MySQL.

If you have upgraded your MassTransit server and do not experience the above error, please disregard this document.

Cause:

Mac OS X Server makes use of MySQL for purposes unrelated to MassTransit and wipes out the MySQL grants table during the 10.4.8 upgrade.

Workaround:

Backup your MassTransit databases. (Please refer to KnowledgeBase article # 243, MassTransit 5.x and 6.x Database Backup Procedures for Mac OS X, for instructions.) You will also need your MassTransit 5.0 or later installer, either the CD or downloaded, and your MassTransit serial number.

Follow the steps below:

  1. Backup your MassTransit databases.
  2. Quit the MassTransit Engine application.
  3. Insert the MassTransit CD or open the MassTransit installer file.
    1. Follow the installer’s instructions.
    2. Enter a password for the masstransit MySQL database user when prompted.
    3. Continue through the installer prompts until complete.
  4. Launch the MassTransit Engine. (If you experience difficulty, please contact GroupLogic Support at 703-528-1555 or support@grouplogic.com for further assistance.)
  5. Start the MassTransit Administrator and check logs to ensure there are no errors.

Please feel free to contact Support in the event of any problems. Also, if you are running MassTransit Enterprise with web client users, check your Apache server’s status.

OS X 10.4.4 and above upgrades require a change to the MySQL configuration files. Please refer to Knowledge base article: Repairing MassTransit Enterprise MySQL Configuration After Mac OS X 10.4.4 and above Server Update (PPC) .

Fix:

See workaround above.

Repairing MassTransit 5.1 and 6.0 Enterprise, Standard and Premier Servers After Mac OS X 10.4.8 Client Update (PPC and Intel)

Thursday, November 16th, 2006

Symptom:

Upgrading Mac OS to 10.4.8 may disable the MassTransit Engine.

Steps to Reproduce:

This article assumes you have the following third-party component versions installed on your MassTransit server:

Mac OS X Client MassTransit MySQL Apache PHP 5
PPC Enterprise/Standard/Premier 5.0.x 1.3.x 5.2.x
Intel Enterprise/Standard/Premier 5.0.x 1.3.x 5.2.x

To Reproduce:

Upgrade Mac OS X 10.4.x Client to 10.4.8. Launch MassTransit Engine.app and the icon bounces on the Dock and then stops. A MySQL connection dialog will pop-up explaining that the MassTransit Engine could not connect to MySQL.

If you have upgraded your MassTransit server and do not experience the above error, please disregard this document.

Cause:

The MySQL grants table is altered. Fixing permissions does not correct this error.

Workaround:

Back up your MassTransit databases. (Please refer to KnowledgeBase article # 243, MassTransit 5.x and 6.x Database Backup Procedures for Mac OS X, for instructions.) You will also need your MassTransit installer, either the CD or downloaded, and your MassTransit serial number.

Follow the steps below:

  1. Backup your MassTransit databases.
  2. Quit the MassTransit Engine application.
  3. Insert the MassTransit CD or open the MassTransit installer file.
    1. Follow the installer’s instructions.
    2. Enter a password for the masstransit MySQL database user when prompted.
    3. Continue through the installer prompts until complete.
  4. Launch the MassTransit Engine. (If you experience difficulty, please contact GroupLogic Support at 703-528-1555 or support@grouplogic.com for further assistance.)
  5. Start the MassTransit Administrator and check logs to ensure there are no errors.

Fix:

See workaround above.

MassTransit and Mac OS X 10.4.8 Updates

Wednesday, November 15th, 2006

Summary:

MassTransit 5.1 and Mac OS X 10.4.8 updates

Description:

The Apple Macintosh 10.4.8 update may alter some operating system and add-on components relevant to MassTransit Professional and Enterprise Servers. Group Logic has tested this update and found that the upgrade has a greater impact on the Server version of OS X 10.4.8 than the Client version. Because of this disparity, separate Knowledge Base articles are available to address issues on the Client and Server versions of OS X 10.4.8.

Note on Intel Mac support: MassTransit can be installed and run on Macs that use Intel CPUs. MassTransit is a PowerPC-based application that runs using Rosetta emulation. MassTransit 5.0.1×29 or later is needed to install MassTransit Pro and Enterprise on Intel Macs. Earlier versions of the MassTransit 5.0 Satellite Server and Application Client also work on Intel Macs. The MassTransit web client plug-in works on Intel Macs with Safari and Firefox if the browser is set to run using Rosetta.

For a complete listing of all system requirements, please see the MassTransit ReadMe.

If you have installed the 10.4.8 upgrade and are experiencing problems with your MassTransit Enterprise and Professional servers, please read the appropriate Knowledge Base article(s) from the Related Posts section.