Posts Tagged ‘Safari’

Is MassTransit Web Client plug-in compatible with 64-bit versions of Windows and Mac OS?

Monday, June 14th, 2010

Summary:

Group Logic supports MassTransit Server on Windows 64-bit platforms. Currently, version 7.0.1 of the MassTransit Web Client plug-in (available for the latest MassTransit HP 7.0.1 Servers) is supported for Safari in 64-bit mode but it is not supported for Internet Explorer running in 64-bit mode. MassTransit Web Client plug-ins prior to version 7.0.1 are not supported for Internet Explorer and Safari browsers running in 64-bit mode. However, you can use the MassTransit Web Client plug-in on a 64-bit operating system by running the browser in 32-bit mode.

If you do not want to switch your browser to 32-bit mode and the HTTP transfer method is available on the server, you can use it to transfer files with the MassTransit Web Client. To use HTTP click, the “Switch to use HTTP” link on the Send Files or Download Files page. For information about how to configure the HTTP transfer method, see the “Windows Web Configuration Instructions” document on the MassTransit Latest Releases page.

If you are using Mozilla Firefox, you shouldn’t have any problems with MassTransit Web Client on 64-bit Windows and Mac, since all current versions of Firefox released by Mozilla are 32-bit.

Description:

To use MassTransit Web Client 7.0.1 via Internet Explorer on 64-bit operating systems, you must run Internet Explorer in 32-bit mode. If you use MassTransit Web Client prior to version 7.0.1, you must run Internet Explorer or Safari in 32-bit mode. The 64-bit platforms of Window and Mac have both the 32-bit and 64-bit versions of Internet Explorer and Safari available.

Set Internet Explorer 8 to run in 32-bit mode on 64-bit Windows

The 32-bit version of Internet Explorer is available in the Start menu. Commonly, the 32-bit Internet Explorer is the default browser. However, some programs will automatically launch the 64-bit version of the browser. To check which version of Internet Explorer is currently running open the Help menu in IE and select About Internet Explorer. If you are running the 64-bit browser, it will say “64-bit Edition“ after the version number. In this case, close Internet Explorer and:

  1. Go to the Start menu->All Programs
  2. Run the 32-bit version of the browser by clicking on the Internet Explorer application.

Set Safari 5 to run in 32-bit mode on 64-bit Mac OS

To run Safari 5 in 32-bit mode:

  1. Quit Safari if it is running.
  2. Open Applications.
  3. In Applications, highlight the Safari application and press Command (Apple) key+I, or open File->Get Info.
  4. In the Safari Info window, mark the Open in 32-bit mode check box and close the window.
  5. Restart Safari.

Now, you can download the MassTransit plug-in for the Web Client and use it to transfer files.

For more information about the MassTransit Web Client plug-in of MassTransit 7, please refer to the Web Client User Guide.

Safari displays files instead of sending them with MassTransit

Thursday, April 13th, 2006

Symptom:

When I drag certain files into the MassTransit plug-in using the Safari browser on Mac OS X 10.4.4, 10.4.5, or 10.4.6, Safari displays the contents of the files instead of sending them. Safari browser on Mac OS X 10.4, 10.5 and 10.6 versions reporting the same bug.

Steps to Reproduce:

Using Safari 2.0.3 on Mac OS X 10.4.4 or later, log into a MassTransit site to send files. Click the Drop Off tab and drag certain file types into the MassTransit plug-in, such as text or PDF files.

Cause:

There is a bug in Safari 2.0.3, which is included with Mac OS X 10.4.4, 10.4.5, and 10.4.6 and later. The bug causes Safari to display certain well-known file types when they are dragged into its window, preventing the MassTransit plug-in from sending them.

Workaround:

Until Apple fixes the bug, there are two options:

A. If using the version of Safari with the bug, click the Select Files button in the MassTransit plug-in to add files through the file selection dialog.

or

B. If you want to drag files into the MassTransit plug-in when using Safari, make sure they are enclosed in a folder and drag the folder in, assuming you want to send all the files in that folder.

Fix:

Group Logic has submitted a bug to Apple Computer about the problem with Safari and is waiting to hear from Apple about when it will be fixed. (Note this article previously indicated that we believed the Safari bug would be fixed in 10.4.6, but the version of Safari included with the public update for 10.4.6 does not appear to contain the fix.)